Kresus sur yunohost suite à mise à jour

#1

bonjour
j’utilise kresus sur yunohost, depuis plusieurs mois, et depuis la dernière mise à jour, au lancement de kresus, j’ai ça

Veuillez installer Weboob en version 1.3 ou supérieure

Afin de fonctionner, Kresus a besoin d’une dépendance unique, Weboob. Kresus n’a pu détecter d’installation fonctionnelle de Weboob (Weboob ou une de ses dépendances n’est pas installé correctement). Pour vous offrir la meilleure expérience possible, il est nécessaire que Weboob soit installé en version stable ou expérimentale (1.3 à ce jour). Contactez l’administrateur de votre Kresus en lui demandant d’installer Weboob manuellement, comme indiqué dans le fichier README : README

pas trouvé la version 1.3 de weboob.
pas de version 1.3 de weboob, chez debian strech.

merci de votre aide

bugs

#2

Bonjour,

peux-tu tenter un

source "/var/www/kresus/venv/bin/activate"
pip install --upgrade weboob

stp, afin de mettre weboob à jour vers la 1.4 (weboob n’est plus dans debian au passage) ?

1 Like
#3

bonjour et merci pour ta réponse.

j’ai fais ta manip, le pip, n’aime pas trop mon python 2.7, mais install de weboob 1.4 ok.
j’ai du enlever le weboob 1.2, avec apt remove.
après un reboot, toujours le même message.

aptitude search weboob donne ça:
idA python-weboob - Weboob, Web Out Of Browsers - library
p python-weboob-core - paquet factice de transition
v python2.7-weboob -
p weboob - applications en ligne de commande pour dia
p weboob-qt - applications Qt pour interagir avec les si

en fouillant, j’ai trouvé un dossier data sous /var/www/kresus. si je copie ce dossier “data”, et refais une install de kresus, je pourrais récupérer mes données ? ou y a t’il un autre moyen ?

merci de ton aide

bugs

#4

Lors de l’installation de la 1.4, tu l’as bien fait dans le virtualenv (avec source "/var/www/kresus/venv/bin/activate" avant le pip install) ?

Il ne faut pas utiliser apt, tu n’auras rien de bon.

#5

oui, j’ai bien fait, source … et dans “venv” le pip install, qui à fini pas install weboob 1.4 ok.
mais, ensuite, quand j’ai fait un aptitude search weboob, j’ai retrouvé le weboob 1.2, donc remove, avec apt.

bugs

#6

bonjour, je suis le mainteneur du paquet Kresus, depuis quelle version as-tu mis à jour ? Je n’arrive pas à reproduire le même problème… mais les conseils de nicofrand sont les bons

ton dernier message dit-il que le problème est résolu ?

#7

tiens, essaye donc de faire ceci :
rendre ce fichier privé :
sudo chmod 600 /var/www/kresus/data/weboob-data/backends
puis redémarre le service
sudo systemctl restart kresus.service

#8

bonjour

merci @jibec. après le chmod, et le restart du service, j’ai accès à kresus.
mais lors de la synchro avec la banque, j’ai une erreur :
Unknown error: 404 Client Error: Not Found.
Erreur inconnue de Kresus : essayez de mettre à jour Weboob, et si cela ne règle pas votre problème, merci de signaler l’erreur aux auteurs de Kresus.

Veuillez vous référer à la console développeurs pour plus d’informations.

la version de weboob etait la 1.2

bugs

#9

bonjour

j’ai fait la dernière mise à jour de kresus, avec le même resultat.
donc j’ai désinstallé kresus, et fait une nouvelle installation, import de mes données tout ok.

mais même erreur, à la synchro avec la banque :
Unknown error: 404 Client Error: Not Found.
Erreur inconnue de Kresus : essayez de mettre à jour Weboob, et si cela ne règle pas votre problème, merci de signaler l’erreur aux auteurs de Kresus.

Veuillez vous référer à la console développeurs pour plus d’informations.

merci de votre aide
bugs

#10

bonjour
je viens de faire une install en virtualbox, d’un kresus sur yunohost.
première connexion, avec ma banque (la banque postale), même erreur :

merci de votre aide

bugs

#11

Bonjour,

as-tu accès aux Préférences à ce stade ? Si oui peux-tu fournir les logs dans “Préférences”, onglet “Journaux” stp ?

#12

bonjour
j’ai accès à “préférences”. je viens de faire un fichier .txt de la tentative de connexion à ma banque (toujours le même message d’erreur).
j’avais fait, une connexion, avec un mot de passe faux, le message est bien “mot de passe erronné”.

je n’ai pas trouvé, le moyen de joindre mon fichier de logs (.txt), donc je mets un lien vers mon cozy:
logs kresus bugs

merci
bugs

#13

Un patch a été appliqué très récemment chez weboob : https://git.weboob.org/weboob/weboob/issues/224.

Peux-tu essayer d’aller dans Préférences, onglet weboob, et re-lancer une mise à jour puis tenter de nouveau le fetch ?

#14

le patch weboob, quelques secondes de mise à jour et c’est tout bon.
j’ai de nouveau, un kresus opérationnel.

merci @nicofrand, @jibec

bugs

2 Likes
#15

:partying_face: Youhouuuuu (faut minimum 20 caractères -_-)

1 Like